Port forwarding in a paperspace Windows 10 machine?


#1

Hey everyone, I just started using paperspace yesterday, and I’m interested in opening a server for a lightweight game. This game needs a specific port to be open via TCP for the players to join the server. I can’t seem to have access to the paperspace router interface, and I’ve tried to open the port with a netsh command and via the Windows 10 Firewall as recommended by the paperspace team, but I can’t seem to do it. Can someone help me? Do you guys know if this kind of thing is even feasible from one of paperspace’s Windows Server machines? This is really the most important thing I’m looking to do on paperspace. I would be really appreciate any advice.

Thanks in advance


#2

Hey @Juansero29 Just add a public IP and you’ll be good to go! We don’t do port-forwarding but adding a public IP will accomplish the same thing.


#3

Hi @Daniel, I’ve actually already added a public IP. I can see my server, but when I try to join it from my computer, I can’t. In the past, this has been always been due to a bad port forwarding configuration. And when checking with a tool like portchecker.co, the port is also shown as closed even when showing correctly my public IP. So adding a public IP by itself doesn’t actually open the port…


#4

@Juansero29 A public IP exposes all ports. If portchecker.co is showing the port is closed, either 1) the service is not listening for a request or 2) the firewall is blocking the connection. Trying pinging the public IP and you should get a response. If so, the machine is publicly addressable on the web / every port is available as long as 1) or 2) are not blocking connectivity.


#5

Hey Daniel! You were correct.

I tried pinging from my physical computer and it worked. So I went again trying to modify the Windows Firewall. I used the Allow an app through Windows Firewall > Change Settings > Allow another app utility. I added the different .exe 's from the game and tried again to launch the server. Even though in-game it still said port-forwarding had failed, now I could join my server without a problem! Maybe the outbound and inbound rules I had set up also had something to do with it working…

So all ports definitely are open and ready to use, we just got to make sure that the app is configured correctly with the Windows Firewall. (or maybe just turn it off? but I didn’t try that).

Thanks! Problem solved :slight_smile: