Paperspace Style Transfer Tutorial


#1

I get the following error when running the job from this tutorial - https://paperspace.zendesk.com/hc/en-us/articles/115004333473-Tutorial-Train-your-first-neural-network-

Awaiting logs…
[FATAL tini (7)] exec /paperspace/run.sh failed: No such file or directory
Job Failed, exitCode 127

Everything is as default and following the tutorial instructions. I’m using Windows 10 x64

Any idea? And how would I tell which path is wrong / where exactly the error is?


#2

@mrboni It looks like there’s a Windows-specific issue where the line-endings are breaking bash. I can create a ticket to see what our options are. In the meantime, I would try using the Windows Ubuntu shell or alternatively, you could specify a GitHub repo instead of a local folder. Here’s an example of the latter that should not break when using Windows:

paperspace jobs create --container Test-Container --machineType K80 --command "bash run.sh" --workspace https://github.com/Paperspace/fast-style-transfer.git

#3

FYI I confirmed both options worked in a Windows environment:

Using Windows Ubuntu shell

Specifying GitHub repo


#4

Thanks Daniel

Are you sure it’s line endings, and not paths (eg / and \ issues) ?


#5

And is the Windows Ubuntu shell a Vm that runs locally?


#6

We did some digging and it appears to be a line-endings issue (and not related to the slash).

In terms of the Ubuntu shell I was referring to, this is the Linux Subsystem which is pretty handy for situations like this. It’s sort of a VM but takes up very minimal resources. In any case, it’s out of beta (stable) and very easy to set up/use. Here is where you activate it within Windows:

image

Just do quick reboot when that completes and then just look for Ubuntu in the start menu:


#7

Oops, someone just noted that you can actually just install this from the Windows Store now which is a bit easier:


#8

Mega thanks Daniel! . . …


#9

Hi Daniel

I finally got some time to try this again - using Ubuntu for Windows 10.

All the setup works fine but when I run the launch command I get the error in the attached image -


#10

@mrboni The issue I see is that you cloned the repo to a location that may not be accessible to the Linux subsystem. I would try navigating to /home/mrboni/ then clone the repo there:

git clone https://github.com/Paperspace/fast-style-transfer && cd fast-style-transfer

Then run the Job with the same command you used previously:

paperspace jobs create --container Test-Container --machineType K80 --command "/paperspace/run.sh"

FYI if you open a new Ubuntu shell, I believe you will be in the /home/mrboni/ directory by default.


#11

Thank you, that worked. I’m new to Linux so this is taking me a while :slight_smile:

I got a gui version of Ubuntu working using the instructions here - https://www.reddit.com/r/Windows10/comments/4w0fbn/full_gui_on_bash_on_ubuntu_on_windows/

This means I have a gui to access the filesystem and copy content between Windows and Linux

One question - I know I can download the results form the Paperspace app, but it there a way to ftp into the /artifacts folder (and also the /storage folder)?


#12

@mrboni This touches on a few points:

Microsoft imposes some limitations around moving files back and forth. I found a link (a bit out of date but most likely still valid) here: https://blogs.msdn.microsoft.com/commandline/2016/11/17/do-not-change-linux-files-using-windows-apps-and-tools/

You could set up a low-cost C class Paperspace Linux instance which may be easier than using the somewhat-hacky Linux Subsystem. Any Linux instance on Paperspace will automatically have access to your /storage directory. Feel free to store anything there that you need to operate on. /artifacts is not a filesystem – it is for static files (think of it like AWS S3). You can manage /artifacts with the CLI or the web interface eg https://paperspace.github.io/paperspace-node/jobs.html#.artifactsGet


#13

Thanks Daniel

I’ve set up a linux virtual machine on PS and am currently downloading some training data to add to persistent storage


#14

Oh, I’ve downloaded the files, and want to copy to /storage, but I don’t seem to have permissions.

I’ve gone to Computer/storage


#15

fixed with sudo nautilus

:slight_smile: