Fast.ai machine won't let me type pw (or anything) into the command line


#1

Just created a machine for the fast.ai course. I need to launch it then paste in the password sent to me. When I launch it and go to type/paste the password into the command line - I can’t type anything at all. Any way to fix this? I’ve tried restarting and using different updated browsers. (I’m located in NZ and chose the CA1 server)


#2

Hey there, can you try using ctrl+shift+v to paste the password to see if that works?


#3

@CujoChuckles Just wanted to follow-up and see if the using ctrl+shift+v helped?


#4

@Daniel I’ve been communicating with the paperspace team. Unfortunately ctrl+shift+v didn’t help. Actually, now the machine just continually loads and I don’t see the command line.


#5

I have the same issue!
I am not sure if it is my problem or the machine’s problem!
But this is driving me crazy :frowning:


#6

Hi @CujoChuckles and @Yen_Pan,

The cursor doesn’t move but it is indeed accepting your keystrokes. This is a security mechanism that you find in many terminal terminal/SSH programs such as putty. If try shift+insert or just manually typing the password and then pressing enter - that should allow you to log in.

As for the continuous loading screen - make sure that your status is Ready (blue button) and not off (grey). If you still see the loading, right click outside the web terminal and reload and enter your credentials again and that should work.


#7

Hello, I have the same problem. The command line does not appear to accept any input from my machine’s keyboard, nor an in-browser keyboard I installed, nor mouse-clicks. I can’t type or paste anything in that (terminal?) window. I tried manually typing the password and hitting enter as suggested, but no luck.


#8

I forgot to mention: here’s what I got back after typing the password and clicking the enter key:

Connection to 10.64.67.48 closed by remote host.
Connection to 10.64.67.48 closed.


#9

Background info: I’m using Win 10 and Chrome.

Switched to Firefox, tried again, did not work, got:
Permission denied, please try again.

And now I have the spinny thing…followed this advice:
“right click outside the web terminal and reload and enter your credentials again and that should work.”
Does that mean re-load the page in my browser or re-start the virtual machine? I reloaded the page in my browser. Same result as above (I pasted the password, got “Permission denied, please try again.”


#10

Same here.
I tried it on 2 different computers with 3 different browser (Firefox,Chrome and Edge) Plus I installed the app.
I will cancel my subscription with paperspace and switch to other providers.
Just wasted 2h of my life.


#11

@Kosta_S @eeeeebeeeee

The terminal is accepting your keystrokes but Ubuntu give you any feedback while you’re typing. This is just how Ubuntu works:

Ctrl+shift+v should work when pasting but just type the password out the first time to get in. You can easily reset your password to something familiar using passwd.

Alternatively, just use SSH. Like some other cloud providers, we provide the web terminal to make the initial setup a bit easier but using SSH is very common.