Error: no such option: -i



I am trying to run the example of working with Gradient CLI from the link here:

I downloaded the GitHub repo to my PC, using the anaconda prompt I ran the command ‘python train/ -i ./data/sal.csv -o ./model/salary’ and it worked fine.
Now I try to submit the experiment using this command: ‘gradient experiments run singlenode --name train --projectId prj0ztwij --container janakiramm/python:3 --machineType C2 --command ‘python train/ -i ./data/sal.csv -o /storage/salary’ --workspaceUrl
I get an error: ‘Error: no such option: -i’

Does anyone know how to fix it?


@IlyaMichlin This just looks like a missing quotation mark issue. I see that you have an open quote before gradient so try removing that. There should only be quotes around the command. You could also try using double quotes if you’re on a Windows system.

Lastly, it looks like the --projectId prj0ztwij from your example is copied from the tutorial. You will want to swap that out with your own project.

Hope that helps!